Confirmed stable and resolved. NOC team will continue to monitor for 24 hours.
Posted May 28, 2026 - 14:43 EDT
Monitoring
We have been informed a fix has been deployed and calls impacted are now routing downstream to us normally. Our NOC team is continuing to monitor calls from the upstream vendor.
Posted May 28, 2026 - 13:42 EDT
Update
We are still waiting for updates from the upstream vendor. All TELAIR networks and functionality and services continue to operate normally.
Posted May 28, 2026 - 13:25 EDT
Identified
The issue has been identified related to one of the upstream vendors having an issue. The issue is affecting incoming calls only to some Toronto based numbers. Updates to follow.
Posted May 28, 2026 - 12:42 EDT
Investigating
We are investigating reports of some incoming calls to Toronto phone numbers are not routing.