Partial outage for some Canadian phone numbers when calling inbound
Incident Report for TELAIR Status Page
Postmortem

Our NOC team is currently observing expected call behavior and is continuing to monitor for prolonged stability.

Posted Apr 13, 2022 - 12:07 EDT

Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 10:20 EDT
Monitoring
We can confirm that the upstream vendor and greater Canadian outage affecting some Canadian phone numbers is now restoring. Calls are flowing through as expecting. We will continue to monitor for the next 24 hours.
Posted Apr 13, 2022 - 10:18 EDT
Identified
We have identified and confirmed that one of our upstream vendors is experiencing issues. They have confirmed the problem and are working on full service restore.

This only affect some Canadian phone numbers.
Posted Apr 13, 2022 - 10:02 EDT
Investigating
We are currently investigating reports of incoming call problems to some Canadian regions.
Posted Apr 13, 2022 - 09:59 EDT
This incident affected: Voice (Inbound calling).