Connect APP is reporting connection failures for some
Incident Report for TELAIR Status Page
Resolved
The issue has been resolved for all users and areas. We will continue to monitor for next 24 hours.
Posted Sep 19, 2022 - 11:20 EDT
Investigating
After multiple reports, we are investigating issues with TELAIR connect app
Posted Sep 19, 2022 - 10:42 EDT
This incident affected: Desktop Application.